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NDSU researchers have developed a low-cost wool fibers grading tool that uses only a domestic flatbed
document scanner and computer software tool developed using open source image processing system. This
project was funded by the American Sheep Industry Association, Colorado. The user scans the fibers sample
and the tool opens the image, analyzes it, and produce measurement results in text, spreadsheet, and graphical
form. The tool analyzes greasy and washed wool types. In the current version, the tool uses internal calibration
obtained from standard samples analyzed using the standard laser-based optical fiber diameter analyzer
(OFDA), but the future versions will have the capability of user-defined calibration to suit variety of imaging
devices and types of fibers analyzed. The step-by-step instruction manual developed for the tool is presented as
follows.
Overall procedure
Wool fibers were scanned in a document scanner and the image was used to measure the fiber widths using anuser developed image processing program tool (plugin) that runs in a readily available (Fiji/ImageJ) open source
software. The developed wool grading plugin tool named NDSU OonSA (Oon = Wool in Hindi; S = Scannerbased; A = Analyzer) is an image processing program that analyzes the image and produces the fiber width
results in graphical and textual forms. Basically, Fiji/Image opens the scanned image file and the plugin analyzes
the image for measurements. High resolution images (e.g., 19200 DPI) are necessary for measurements as the
wool fiber widths are in micron scale.
Quick instructions

1. Supplies required
• A computer: Used to run the analysis. A desktop or laptop (windows or mac) will work. NDSU OonSA plugin
will run on most machines. More RAM will perform faster processing.
• A flatbed document scanner: Used to obtain the digital image. The scanner should able to produce high
resolution images with DPI  19,200 (which is equivalent to 1.3 micron measurement accuracy). Ensure
that the scanner software allows for custom DPI setting so that this high value can be set while scanning.
However, the plugin can operate on any digital image produced by any device (e.g., microscope), provided
the DPI of the image and is high enough for fiber measurements were made available. Using scanner is an
attractive low-cost option.
• Transparent films: Used to protect the glass bed of the scanner.
• Clear cover glass: Used to hold the wool fibers in place. Good quality picture frame glasses will also serve
the purpose.
• Holding weight: Used to reduce the lifting and air gaps among fibers. If a custom made frame is available or
fabricated, it will be efficient. Otherwise, any suitable weights can be employed.

• Cleaning supplies: Microfiber lens cleaning cloth, glass cleaning liquids, and paper towels. Used to clean
the glass bed of scanner, cover glass, and general cleaning.
• Optional - A cardboard enclosure box: Used to avoid ambient light that interferes with the scanned image.
Inside of the box painted with non-reflecting black. The box should be large enough to enclose the scanner
when its lid is open and vertical. When a suitable environment is available (no lights above the scanner),
there is no need for this enclosure box.
2. Prepare the wool samples
• Clean the wool samples to be measured to remove any foreign material.
• Washed or greasy wool samples can be used.
• Spread the sample between fingers and ensure it can fit under a 4” by 5” glass cover.
• The actual size of window available for scanning is 2” by 3.5” from the stainless steel frame that covers the
glass piece.
3. Layout the sample on scanner
• A good quality document scanner that can produce high resolution scans (e.g., 19200 DPI (dots or pixel
per inch) = 1.3 micron resolution) is necessary. Lower resolution may not be suitable for wool fiber
diameter measurements.
• Lay a sheet of good quality transparent film on the glass bed of scanner (e.g., overhead projector film). This
protects the glass bed and the film can be replaced when becomes greasy.
• Spread the sample on the transparent film gently.
• Place the glass cover on the spread fibers. This keeps the sample in place.
• Place the steel frame on the glass cover. Steel frame gently compresses the fibers so that they all rest in a
plane without air gaps (Fig. 1).
4. Scanning the image
• The scanner software – sometimes called “scanner gear” should be opened, after powering ON the
scanner. This will bring up the scanner input and image windows (Fig. 1).

Figure 1. (A) Scan preview showing the scanner bed (black), transparent sheet, glass cover, stainless steel plate, wool sample,
and “marching ant” window of selected scan area, and (B) scanner software’s scan gear “Advanced Mode” allows for user
settings before scanning where “Input Settings” of 0.5 x 0.5 in, “Output Resolution” of 19200, scan “Preview”, and actual
“Scan” options and commands are issued for wool fiber image capture. The maximum size of the scan window is 0.53” x
0.73” and any smaller size windows will also work at 19200 DPI.

• As the wool fibers are cream to white in color, a black background gives the best contrast.
• Methods of achieving black background include (i) a black painted enclosure box with non-reflecting or
non-glossy paint, (ii) keeping the scanner lid open and ensuring no light sources are right above the scanner.
• A quick pre-scan should be performed by pressing the “Preview” button (Fig. 1B). This brings up the image
of the wool fibers with steel frame.
• Scanner software options were set so that the actual scanning widow’s size is 0.5” x 0.5”.
• Set the output DPI as 19200. For the scanner used at present, the 0.5” square window size at 19200 DPI is
a good working size of image that can obtained from the scanner.
• Usually the scanner will have a limitation on the maximum number of pixels that go into the image on both
direction (horizontal – x and vertical – y; e.g., 10,208 and 14,032). These limits will translate to 0.53” x
0.73” at 19,200 DPI as the scan window (SW) size. Therefore, it is possible to have other sizes of SW within
this size limit (e.g., a narrower window of 0.2” x 0.7” is a valid for scanning).
• Once the scanning window is set, a corresponding square with “marching ants” will be seen on the scanner
software interface.
• This scanning window can be moved anywhere in the scan area, and should be moved to appropriate
location of wool fibers seen in the preview (Fig. 1A). This window will become the actual image after
scanning.
• After positioning the scanning window, the actual scan can be collected by pressing the “Scan” button (Fig. 1B).
• When the scanner lid is open, it is always safer not to look at the light source of the scanner, which may be
harmful to the eyes.
• The light source of the scanner quickly reaches the scanning window and the actual scan proceeds at a
slower pace.
• Once the scan is completed in about 30 seconds, the image will be stored in the computer (usually the “My
Documents” file), using some default naming convention (e.g., IMG_2016***.jpg).
• The scanner software also loads and displays the image, and the scanning of next sample or replication can
be continued, without to wait for the display unless the images need to be seen.
• Sometimes, based on the setting, closing the image that was scanned is required to save the image to the
computer in the “My Documents” folder.
5. Installing ImageJ and NDSU OonSA
• The developed software plugin (NDSU OonSA) will run in Fiji or ImageJ software platform. Fiji can be
downloaded and installed freely from (http://fiji.sc/Downloads#Fiji) for windows or mac. As the software
website says (http://imagej.nih.gov/ij/features.html): “ImageJ and its Java source code are freely available
and in the public domain. No license is required.” The downloadable ImageJ User Guide (http://imagej.nih.
gov/ij/docs/guide/user-guide.pdf) describes the software in detail.
• Alternatively, the entire Fiji/ImageJ software with NDSU OonSA preinstalled are supplied as a single folder
made available through a flash drive.
• The NDSU OonSA plugin is actually an ImageJ plugin, which comes in the form of “jar” file, that can be
installed as a plugin in an existing Fiji running in a user computer.
• Once installed from the jar file the plugin will become an integral part of the Fiji/ImageJ system.
6. Opening Fiji/ImageJ and loading the image
• Fiji/ImageJ can be opened by double-clicking the *.exe on windows or the application file named Fiji in
mac. When opened, the software will be similar to that shown below (Fig. 2) on a windows platform.

Figure 2. The main screen of the Fiji/ImageJ software. The menu items “File” and “Plugin” can be used to open the image
first and analyze using the plugin tool.

• Fiji/ImageJ main screen has it title bar (Fig. 2, first row), several items in the menu bar (second row),
convenient command tool buttons in toolbar (third row), and status bar (fourth row). Of these items “File”
and “Plugin” menus and scrolling tool will be enough for developed plugin.
• At the time of plugin development, the ImageJ version used was 1.50f, and is expected to run on previous
and future versions as well, as ImageJ versions support backward compatibility of plugins.
• Image to be analyzed is loaded or opened in the Fiji either by (i) drag-and-drop the image file of interest in
the Fiji main screen anywhere in the toolbar or status bar (third or fourth row) or (ii) File > Open and
navigating to the image file location (Fig. 2).
• The progress bar shows the loading status and the image will be displayed (Fig. 4A) shortly.
• The image opened can be of any type such as color, gray scale, or binary. The plugin will ultimately convert
the image into binary for analysis automatically.
7. Operating the NDSU OonSA plugin
• Once the image is opened, the OonSA plugin will directly preprocess and analyze the image. Two versions
to work on mac and windows were developed and supplied.
• The OonSA plugin resides in the “Plugins” menu and can be operated by Plugins > A NDSU OonSA Windows
commands (Fig. 3).

Figure 3. The actual developed plugin tool “A NDSU OonSA Windows” found under “Plugins” menu item which operates on
the opened image and analyzes the wool fibers.

• When the plugin is opened will bring up the “Inputs Panel”, where some the values are shown as default
(Fig. 4B).
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Figure 4. (A) A typical 0.5 by 0.5 at 19200 DPI scanned image opened for analysis through File > Open commands or dragand-drop operation. (B) Only input panel of the tool where users can input their image DPI (19200 is default), type of wool,
Ear tag ID, and have an option of seeing the widths measure from top to bottom going from left to right.

• DPI value of the image, which was used to produce the image while scanning, is input in the text box
(19200 is set as default).
• Type of wool (Washed, Greasy, or Calibration) can be chosen from the choice text box (Greasy is set as
default), as most measured wool are greasy.
• Ear tag information, such as ID or other relevant information can be fed into the text box.
• Check box “Draw widths!” can be opted to see a plot all the widths measured from top to bottom (drawing
of widths is set as default – and can be switched off if desired).
• After entering the relevant inputs in the fields, the OK button or ENTER should be clicked to run the plugin
and generate the results.
8. Results outputs
• A. Textual output: The plugin will produce the results in several forms for better visualization,
documentation, storage, and further analysis.
• The immediate results will be available in the textual form as results “Log” (Fig. 5).
• The results summary of measurements including
the information about the sample with date will
be produced in this results log.
• This log output window accumulates the results
of all sessions and can be saved into compatible
forms (e.g., *.txt) from its “File” menu (Fig. 5).
• When the log is closed the results will be lost, if
not saved, and each run will bring up the log
window, if closed with the current results, or
append it to the opened log.
• B. Graphical output - default: Another default
output is a plot of frequency histogram of
measured widths in micron on x-axis and
percentage of fibers belong to that category in
y-axis (Fig. 6). The results summary
details were also included in the plot.
Figure 5. Textual output of the analysis results summary in
• The results summary details were also included
the form of log window. This log window will accumulate all
the results of any session of analysis and can be copied for
in the plot. If necessary this plot can be saved
storage or report.
into compatible forms (e.g., *.png, *.jpg) from
the Fiji main menu after
making the plot as
active window through File >
Save As commands
and selecting the required
image formats.
• A default of 50 frequency
intervals was considered for
this calculation and plot.
• C. Graphical output optional: An optional
graphical output is the
continuous plot of widths
measured with their labels
on the x-axis and the widths
in micron on the y-axis
Figure 6. Graphical output frequency histogram of the results. The measurements
were divided into 50 frequency intervals based on the size range and the percentage
(Fig. 7).
of fibers filling in the range were plotted.

Figure 7. Graphical output measured widths. Each red dot is the average of 12 measurements on the qualified fiber
segment and the measurements were made from top to bottom from left to right on the image (Fig. 4 A) and were
plotted continuously.

• As indicated before this optional output is obtained by opting for it through the choice of “Draw widths!”
of plugin input panel (Fig. 4B).
• Similar to frequency histogram plot (Fig. 6), the width plot contains results summary and can be saved as
image, if necessary.
9. Interpreting the results
• One can have a closer look on the measurements made in the image and the selection of fiber segments
that qualifies for measurement or to be included in the calculation by zooming in the processed image
(Fig. 8).

Figure 8. Display of actual measurements on the fibers in the enlarged processed image. The red numbers indicate the
labeled measurements that were used in the analysis, blue crosses indicate probable segments that were not overlapping
that were measured but not included in the analysis, the gray lines around the crosses indicate 12 actual width
measurements that were averaged for calculation.

• Using the ‘+’ or ‘-’ key repeatedly or “up or down” arrow keys the image can be enlarged or shrunk, and
using the scrolling tool (Fig. 2) the image can be panned.
• The method of measurement employed is digitally chopping the wool fibers by overlaying a square grid,
checking the shape of the chops, selecting chops of single fibers, measuring 12 widths from the center and
finding their average and standard deviation (STD), and including the measurement when the STD is less
than 12.5% and chops are not interfered with the overlaid grids.

• This means several chops that represent overlapping fibers (Fig. 8 - seen as branches) and odd shapes
based on assumed shape factors, such as roundness, circularity, solidity, area fraction were not qualified
for measurements (Fig. 8 - left as unmeasured white chops).
• All the qualified measured segments (Fig. 8 - red labeled) with their average values were used in the
calculations and the various results were produced (Figs. 5-7, 9).
• The number of qualified segments can be increased by trying to lay out the fibers in a non-overlapping
layout, which is a basic requirement for any fiber measurement devices.
• Thus, more qualified segments will increase the measurement accuracy (> 100 segments is suggested).
• In the plugin internally calibration equations were used exclusively for washed and greasy wool fibers.
These calibration equations will convert the image based widths measured using pixels into micron units
that is readily usable. The accuracy of measurement will depend on these calibration equations.
• The calibration equations were actually made by subjecting a complete set of USDA certified wool sample
through the standard Optical Fiber Diameter Analysis (OFDA) and through NDSU OonSA.
• From these average measurements, number of measurements, minimum, maximum, median, mean,
standard deviation, and coefficient of variation (CV) were calculated and results produced with other fiber
sample information.
10. Storing the results
• The plugin also stores the results in a “comma separated value” (*.csv) formatted file that can be readily
opened in a spreadsheet program (Fig. 9).

Figure 9. Spreadsheet output of the results analysis summary. This file is automatically generated if not present or will be updated
with new results and stores the results of all sessions. The contents can be copied for storage/report or further analysis readily as
they are in spreadsheet format.

• This file named “WoolResultsWin.csv” or “WoolResultsMac.csv” will reside in the Desktop of the computer.
• This file appends all the new results of the measurement sessions at the end and will grow as
measurements were made in any session and will not vanish unlike the results log (Fig. 5).
• As before, all results summary and sample information were stored in this file in the form of measurement
history.
• This file can be copied under different name for storage and cataloging.
• When deleted, a new file will be automatically generated by the plugin, but the past history of
measurements will be lost.
• As the data is in a spreadsheet-ready format, it can be subjected to further analysis and plotting using the
spreadsheet program.

11. Troubleshooting
• The plugin tool uses ImageJ and runs off it and tries to update automatically when new versions are made
available. Updating to the newest version, sometimes freezes the plugin. So in general, it is not necessary
to update ImageJ – to be on conservative side.
• However, when precautions are taken in terms of backing up the previous version then updating can be
carried out and in most cases will run without issues and in such cases the latest version can be retained.
• But, in any case it will be perfectly okay to use the initial version as the accuracy will not vary among the
versions of ImageJ.
• Sometimes, for want of running memory and when commands issued too quickly (clicking buttons before
the previous process finished) the output image will be black or text results blank. When the same image is
run again the issue will be resolved.
• When the outputs were blank, rerunning the image again (after closing the existing image) or closing the
Fiji itself will solve the issue.
• The developers can be contacted for any questions, updates, and bugs fixing through email (Igathinathane.
Cannyen@ndsu.edu or christopher.schauer@ndsu.edu).

